Obs ruckler und stottern

Discord-Logo Komm auf unseren Discord-Server! Direkt und ohne Umschweife - klick hier!
  • Hallo,


    ich wollte mal fragen ob ihr mir weiterhelfen könnt. Ich habe das Problem dass ich extreme Ruckler und stottern bei Obs habe...


    was habe ich schon versucht?

    Vorschau an aus

    alle möglichen Einstellungen getestet und sogar mein PC komplett neu aufgesetzt.

    Liegt es an SLI? wenn ich SLI deaktiviere kein unterschied (leider)

    Wenn ich mit Xsplit teste geht alles... aber ich würde schon lieber Obs Streamlabs verwenden weil bestes Programm !!!

    Wenn ich Games auf mein PC spiele läuft es Flüssig ... sogar wenn ich Sli aktiviert habe !!!!!

    Aber sobald ich auf die Elgato Scene gehe ruckelt alles !!!


    Mein PC


    Mainboard: MSI x399

    Cpu: AMD Threadripper 1950x 16 Kerne 4,1 Ghz

    Wasserkühlung

    Grafikkarte: 2x GTX 1080 8gb Aero MSI mit SLI Unterstützung

    Arbeitsspeicher: 32gb @ 3200 MHZ


    Ich Frage mich warum es bei mir nicht funktionieren will. Und es nervt mich :-(

    Beide Grafikkarten sind auf einem 16x 3.0 PCIe Slot

    Ich Streame mit 900p 60 fps auf Slow x264 (wenn ich weniger z.b. Medium verwende ist leider auch kein Unterschied)

    Ich habe auch noch ne Elgato HD 60pro und eine HD60S (auch kein Unterschied ruckelt und stottert bei beiden)

    Bitte helft mir....

    Danke

  • Moinsen,


    du hast zwar schon einige einstellungen geschrieben, aber mach mal trotzdem bitte noch Screenshots von deinen Einstellungen und poste sie hier bitte.


    Aber schonmal Lösungsansätze:


    Spielaufnahme oder Monitoraufnahme?


    Bei Spielaufnahme hast du den SLI/Crossfire-Aufnahmemodus aktiviert?

    Hast du vielleicht den Haken bei "Limitiere FPS der Aufnahme" drin?

  • Danke für die schnelle Antwort..


    Spielaufnahme oder Monitoraufnahme?


    Bei Spielaufnahme hast du den SLI/Crossfire-Aufnahmemodus aktiviert? - ich verwende die Monitor Aufnahme..


    Hast du vielleicht den Haken bei "Limitiere FPS der Aufnahme" drin? - nein


    wenn ich über den PC spiele und Streame läuft alles Flüssig... Solange ich die Grafikkarten unter 80% Auslastung für das Spiel ausslaste...


    Ich habe noch ne Ps4 mit der ich bo4 streame mit einer Elgato Hd60 Pro, da stottert das Bild ein wenig und manchmal ruckelt es.. ich habe auch noch eine elgato hd60s zuhause und bei der habe ich genau das selbe problem..

  • Das Problem wäre gelöst, wenn du CPU usage Preset auf veryfast stehen läst.


    Kurz erklärt, CPU preset ist die codierung stärke, und umso höher du einstellst, umso mehr benötigt die CPU mehr Power ;)

    Würde mir wünschen, wenn man Hilfe benötigt, das man nicht nur schreibt "habe alles durchgetestet usw"


    Postet Bilder von jeweiligen Einstellungen, denn, Bilder sagen mehr als 1000 Worte.


    Einfach gesagt, umso mehr Informationen wir haben, umso besser und efektiver können wir alle gegenseitig helfen.


    Da spart auch "ihr" die warterei, bis da einer Helfen kann


    :thumbup::thumbup:

  • danke für die info


    ich habe einen 16 kerne Prozessor... die max auslastung ist bei 50%... und wenn ich auf 720p 60fps streame ist die auslastung nur bei 25% !!! und wie gesagt es geht um die elgato... weil wenn ich streame und spiele auf dem pc habe ich bei 1080p 60fps eine auslastung von 60% und da läuft es flüssig...


    Sagen wir mal so


    Stream PC / Spiel PC = Flüssig


    Stream PC / Elgato HD 60 Pro Ps4 = Ruckler und Stottern


    wenn man da länger ein stream guckt bekommt man doch augenschmerzen...


    ich bin so ratlos :-(

  • 16 Kernen sagen recht viel aus, ich habe selbst ein 16 kernen amd ryzen 1700, und der schafft selbst mit slow 720 p und 60 fps. der ryzen wird nur als streaming benutzt ;)


    glaub mir ;) auch wenn ich mit dem ryzen zocken würde, hätte ich das gleiches problem wie du ;)

    Würde mir wünschen, wenn man Hilfe benötigt, das man nicht nur schreibt "habe alles durchgetestet usw"


    Postet Bilder von jeweiligen Einstellungen, denn, Bilder sagen mehr als 1000 Worte.


    Einfach gesagt, umso mehr Informationen wir haben, umso besser und efektiver können wir alle gegenseitig helfen.


    Da spart auch "ihr" die warterei, bis da einer Helfen kann


    :thumbup::thumbup:

  • hä? ich sagte ich zocke nicht auf dem PC aber wenn ich zocke und streame funktioniert alles !!!! nur mit der ELGATO nicht !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


    weist du überhaupt welches problem ich habe?

    hast du dir das überhaupt genau durchgelesen?


    Ok wenn du glaubst dass es was bringt dann stelle ich auf veryfast und streame mit 1% cpu last ;-)

    • Hilfreich

    Also...um hier mal zu schlichten:


    der Threadripper besitzt 16 logische Kerne und zusätzlich noch 16 virtuelle Kerne. Sprich er hat sogar 32 Threads, mit denen er arbeiten kann. Der Threadripper kann, und ich übertreibe nicht, wenn ich sage, LOCKER den slow preset fahren. Ich selber hatte auch einen Threadripper, aber da er mir zu hungrig war, habe ich ihn wieder verkauft.


    Der Threadripper ist ein rendering Monster. Und gerade im bereich des Streamings benötigt man viel Rechenleistung. Sprich: je mehr Kerne, um so mehr renderperformence. Das Stottern, welches er beschreibt, kommt nicht von der CPU. Es ist durchaus möglich, das es vom SLI kommt.


    Meine Lösungsansätze waren im übrigen völliger Unsinn. Da du ja über die Capture Card gehst, brauchst du ja Videoaufnahmequelle und nicht Spieleaufnahme. Und in der Videoaufnahmequelle gibt es die Einstellung für SLI nicht.

    Du kannst demnach schauen, welche Auflösung du bei dieser Quelle genommen hast und wieviel FPS.

    Am besten auf Pufferung auf Automatisch lassen.

  • x@thecrow

    hä? ich sagte ich zocke nicht auf dem PC aber wenn ich zocke und streame funktioniert alles !!!! nur mit der ELGATO nicht !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


    weist du überhaupt welches problem ich habe?

    hast du dir das überhaupt genau durchgelesen?


    Ok wenn du glaubst dass es was bringt dann stelle ich auf veryfast und streame mit 1% cpu last ;-)

    sorry, das habe ich nicht ganz.


    Neben Frage von mir, hast du versucht, über den Elgato Capture card software zu streamen?

    Würde mir wünschen, wenn man Hilfe benötigt, das man nicht nur schreibt "habe alles durchgetestet usw"


    Postet Bilder von jeweiligen Einstellungen, denn, Bilder sagen mehr als 1000 Worte.


    Einfach gesagt, umso mehr Informationen wir haben, umso besser und efektiver können wir alle gegenseitig helfen.


    Da spart auch "ihr" die warterei, bis da einer Helfen kann


    :thumbup::thumbup:

  • Hallo,


    sorry falls ich ein wenig unsympatisch war... war einfach genervt von dem stottern... ich habe gestern und heute mit dem Elgato Support geschrieben und die leiten das an die Entwicklung weiter...


    ich beschreibe euch mal die Situation:


    3sec. flüssig - 3sec. zittern - 3sec. stottern - kurzer minimaler ruckler und dass in unregelmäßigen abständen...


    xlTheCrow


    jep der Amd ist richtig hungrig aber mit dem Mittlerweile effizienten Energiesparmodus/Balanced-Mode (wenn ich nicht streame) geht es noch so halbwegs LuL...


    Habe gestern noch jede menge gemacht und dabei auch die älteren Treiber von Elgato installiert...

    Heute getestet und das Bild ist ganz anders .. viel bessere Qualität .. kein Pixel auf Slow mit 5.500 Bitrate...

    was ja an und für sich gut ist, aber es ruckelt immer noch :-(


    ich teste gleich mal etwas unter 60fps zb. 59fps


    vl. bringt das ja was...


    danke nochmal :-)

  • ja ne also so halb.. ich habe alle Kerne am laufen und auch 32 Threads , aber ich habe die Speicheraufteilung auf Lokal da dass generell weniger Strom zieht und besser bei Games ist und somit ist der Pc viel leiser aber ich ich hab da auch schon alle möglichen Einstellungen durch.. daran liegt es nicht..


    Gute Nachricht : ich habe gerade das Ruckeln/Zittern/Stottern EXTREM verringern können.


    ich habe bei der Elgato Game Capture Software die Fps auf 30 reduziert..

    bei Obs auch auf 30 bei der Video Quelle..


    Streameinstellungen sind jetzt:


    1600x900p 60fps

    x264 slow high

    5500 bitrate


    Ich glaube dass die Elgato nicht mit Sli klar kommt und somit dann diese Ruckler entstehen..


    Danke für die Hilfe, ihr seid die Besten !!!!


    Eine Frage hätte ich da noch, und zwar: wie kann ich das am Bild am besten einstellen, wenn ich über den PC spiele und streame? also Bildschirmaufnahme oder Gamecapture und Sli/crossfire an aus?? weis das einer?

  • was mir noch einfällt. Du schriebst nicht wie viel Watt dein Netzteil hat.


    Hast du deine 2 elgato am anderen PC probiert?


    2te Grafikkarte ausgebaut?


    Das sind noch die Ideen, die ich noch hätte.




    Zur deine Frage am Schluss, da kannst du bildaufnahme bzw Gamern Aufnahme benutzen.


    Oder wenn du interne capture card hast kannst die dann auswählen, Nachteil da streamst du alles mit, Ausnahme du machst ein Logo oder ähnliches rein wenn keiner das sehen soll was auf deinen Desktop hast bzw machst.

    Würde mir wünschen, wenn man Hilfe benötigt, das man nicht nur schreibt "habe alles durchgetestet usw"


    Postet Bilder von jeweiligen Einstellungen, denn, Bilder sagen mehr als 1000 Worte.


    Einfach gesagt, umso mehr Informationen wir haben, umso besser und efektiver können wir alle gegenseitig helfen.


    Da spart auch "ihr" die warterei, bis da einer Helfen kann


    :thumbup::thumbup: